九度oj-1005

题目描述:

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

• The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
• If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
• Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
• If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

输入:

Each input file may contain more than one test case.
Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

输出:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

样例输入:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

样例输出:

0 10
3
5 6 7
2 8

1 4

代码

#include <iostream>  
#include <vector>  
#include <algorithm>  
using namespace std;  

int main(){  
int N,M,K;  
vector<int>vec;  
while(cin>>N>>M>>K){  
    int *sc = new int[M];  
    int *index = new int[N];  
    int *result = new int[N];  
    int *priority = new int[N];  
    for(int i=0;i<N;i++)  
        priority[i] = i;  
    for(int i=0;i<N;i++)  
        index[i] = i;  
    int (*sgrade)[2] = new int[N][2];  
    int *sfinal = new int[N];  
    int (*schoice)[5] = new int[N][5];  
    for(int i=0;i<M;i++)  
        cin>>sc[i];  
    for(int i=0;i<N;i++){  
        cin>>sgrade[i][0]>>sgrade[i][1];  
        sfinal[i] = (sgrade[i][0]+sgrade[i][1])/2;  
        for(int j=0;j<K;j++){  
            cin>>schoice[i][j];  
        }  
    }  
    for(int i=0;i<N-1;i++){  
        for(int j=i+1;j<N;j++){  
            if(sfinal[i]<sfinal[j] || ((sfinal[i]==sfinal[j])&&(sgrade[i][0]<sgrade[j][0]))){  
                int temp = sfinal[i];  
                sfinal[i] = sfinal[j];  
                sfinal[j] = temp;  
                int t = index[i];  
                index[i] = index[j];  
                index[j] = t;  
            }  
        }  
    }  
    for(int i=0;i<N-1;i++){  
        if((sgrade[index[i]][0] == sgrade[index[i+1]][0])&&(sgrade[index[i]][1] == sgrade[index[i+1]][1]))  
            priority[i+1] = priority[i];  

    }  
    int resourse = -1;  
    for(int i=0;i<N;i++){  
        for(int j=0;j<K;j++){  
            if(sc[schoice[index[i]][j]]>0 || ((i!=0)&&(priority[i] == priority[i-1])&&(schoice[index[i]][j] == resourse))){  
                result[i] = schoice[index[i]][j];  
                resourse = result[i];  
                sc[schoice[index[i]][j]] --;  
                break;  
            }  
            result[i] = -1;  
        }  
    }  
    for(int i=0;i<M;i++){  
        for(int j=0;j<N;j++){  
            if(result[j] == i){  
                vec.push_back(index[j]);  
            }  
        }  
        sort(vec.begin(),vec.end());  
        for(vector<int>::iterator it=vec.begin();it!=vec.end();it++){  
            if(it == (vec.end()-1))  
                cout<<*it;  
            else  
                cout<<*it<<" ";  
        }  

        while(!vec.empty())  
            vec.pop_back();  
        cout<<endl;  
    }  
}  
return 0;  
}  

作者提醒

这道题虽然不难,题目意思也很容易理解,但是做起来相当繁琐。
题目意思是,有多个学校,多个学生,每个学生可以填报多个学校。首先,按学生的成绩排序,
成绩高的学生优先选择学校,同一排名的学生选择的权利一样,即使学校的名额用完了。
首先进行学生成绩的排序,然后按他们的次序顺序选择学校即可。做的时候耐心点就好了。
这里关键一点是 输出每行的最后一个数,要把空格去掉。。

一只狗的提醒

想了想自己可能很多地方想的不全面反而影响你的思路,看代码我都能看懂的你怎么可能看不懂呢,
以后我就找些作者提醒的东西吧,
让你能有个地方找到这些题目和解答就好了。
本来是想找个u盘做个文件夹,想想太麻烦了,还是找这么个地方,让你随时都可以看好了。这样你就不用搜很多博客了