九度oj-1002

题目描述:

Grading hundreds of thousands of Graduate Entrance Exams is a hard work. 
It is even harder to design a process to make the results as fair as possible. 
One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
• A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
• If the difference exceeds T, the 3rd expert will give G3.
• If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
• If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
• If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

Each input file may contain more than one test case.
Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:

20 2 15 13 10 18

样例输出:

14.0

代码:

#include<stdio.h>
int main(){
int p,t,g1,g2,g3,gj;
float grade;
while(scanf("%d%d%d%d%d%d",&p,&t,&g1,&g2,&g3,&gj)!=EOF)
{
    if(abs(g1-g2)<=t)
    {
          grade=(g1+g2)/2.0;                  
    }
    else if(abs(g2-g3)<=t&&abs(g1-g3)<=t)
    {
         int max=g1;
         if(g2>max)
              max=g2;
         if(g3>max)
             max=g3;
         grade=(float)max;  
    }else if(abs(g2-g3)>t&&abs(g1-g3)>t){
           grade=(float)gj;
    }else{
         if(abs(g1-g3)>abs(g2-g3)){
                grade=(g2+g3)/2.0;
         }else{
                grade=(g1+g3)/2.0;
               } 
    }
    printf("%.1f\n",grade);
    }
}

一只狗的提醒:

题目就是大致说公平算分的事,就是先给定一个T,
如果 |G1 - G2| ≤ T 那结果就是G1 G2平均值
要是不符合这个条件 就看G3
如果|G2 - G3| ≤ T 与 |G1 - G3| ≤ T 只有其中一个成立的话 就找和G3最接近的一个数,
然后两个取平均值
比如G1 G2 G3分别是  3 6 4 因为G1比较近嘛 两个就差1 最后结果就是(3+4)/2
如果|G2 - G3| ≤ T 与 |G1 - G3| ≤ T 都成立 就取 G1 G2 G3三个里面的最大值
如果都不符合就取gj
一定要看到(g1+g2)/2.0 不是2 因为他这个真的是会算很多数据 考虑的很全面 
一开始我也以为是人家语法的问题 其实是她会测试很多数据 有一组不可以就不行,
还有看题:The answer must be accurate to 1 decimal place. 
精确到小数点后一位 也提示了/2.0