九度oj-1001

题目描述:

This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

The input is terminated by a zero M and that case must NOT be processed.

输出:

For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:

2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0

样例输出:

1
5

代码:

#include <stdio.h>  
int main()  
{  
    int M,N;  
    int i,j,count,a;  
    int m[10][10];  
    while (scanf("%d %d",&M,&N)!=EOF&&M)  
    {  
        count=M+N;                            //最后输出的计数值。这是一个关键点,如果从零开始计数,则会很//困难;所以就用减的方法。  
        for (i=0;i<M;i++)  
        {  
            for (j=0;j<N;j++)  
            {  
               scanf("%d",&m[i][j]);  
            }  
        }  
        for (i=0;i<M;i++)  
        {  
            for (j=0;j<N;j++)  
            {  
                scanf("%d",&a);  
                m[i][j]+=a;               //直接对矩阵相加  
            }  
        }  
        for (i=0;i<M;i++)  
        {  
            for (j=0;j<N;j++)  
            {  
                if (m[i][j]!=0)  
                {  
                    count--;  
                    break;  
                }  
            }  
        }  
        for (i=0;i<N;i++)  
        {  
            for (j=0;j<M;j++)  
            {  
                if (m[j][i]!=0)  
                {  
                    count--;  
                    break;  
                }  
            }  
        }  
        printf("%d\n",count);  
    }  
    return 1;  
}  

一直狗的提醒:

题目大意是要求输入两个整数M,N,然后分别输入两个M行N列的矩阵 将两个矩阵相加。
最后输出的是相加后的矩阵中全部是0的行数和列数,我自己写的太麻烦了,特别长 
感觉你参考的话还是参考这些有用的比较好 我准备以后有答案的就不写了,多参考几个好的给你